绝代码农 发表于 2021-7-21 16:32:28

hdu 5791 Two dp

Two

题目连接:
http://acm.hdu.edu.cn/showproblem.php?pid=5791

Description
Alice gets two sequences A and B. A easy problem comes. How many pair of sequence A' and sequence B' are same. For example, {1,2} and {1,2} are same. {1,2,4} and {1,4,2} are not same. A' is a subsequence of A. B' is a subsequence of B. The subsequnce can be not continuous. For example, {1,1,2} has 7 subsequences {1},{1},{2},{1,1},{1,2},{1,2},{1,1,2}. The answer can be very large. Output the answer mod 1000000007.

Input
The input contains multiple test cases.
For each test case, the first line cantains two integers N,M(1≤N,M≤1000). The next line contains N integers. The next line followed M integers. All integers are between 1 and 1000.

Output
For each test case, output the answer mod 1000000007.

Sample Input
3 2
1 2 3
2 1
3 2
1 2 3
1 2

Sample Output
2
3

Hint

题意
给你两个数组,问你公共子序列的数量是多少

题解:
dp表示第一个串考虑到i位,第二个串考虑到j位的答案是多少
那么dp = dp+dp-dp
如果a=b,dp+=dp+1
就好了

代码
#include <bits/stdc++.h>

using namespace std;

const int pr=1000000007;
int dp;
int n,m;
int a,b;

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
      for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++) dp=0;
      for(int i=1;i<=n;i++)
            scanf("%d",&a);
      for(int i=1;i<=m;i++)
            scanf("%d",&b);
   //   for(int i=1;i<=n;i++) dp=1;
   //   for(int i=1;i<=m;i++) dp=1;
      for(int i=1;i<=n;i++)
      {
            for(int j=1;j<=m;j++)
            {
                dp=dp+dp-dp;
                if(a==b) dp+=dp+1;
                if(dp<0) dp+=pr;
                if(dp>=pr) dp%=pr;
             //   cout<<i<<" "<<j<<" "<<dp<<endl;
            }
      }
      cout<<dp<<endl;
    }
    return 0;
}

文档来源:51CTO技术博客https://blog.51cto.com/u_15303184/3108586
页: [1]
查看完整版本: hdu 5791 Two dp