Mike 发表于 2021-7-31 16:19:11

顺序表应用3:元素位置互换之移位算法

Problem Description
一个长度为len(1<=len<=1000000)的顺序表,数据元素的类型为整型,将该表分成两半,前一半有m个元素,后一半有len-m个元素(1<=m<=len),借助元素移位的方式,设计一个空间复杂度为O(1)的算法,改变原来的顺序表,把顺序表中原来在前的m个元素放到表的后段,后len-m个元素放到表的前段。
注意:先将顺序表元素调整为符合要求的内容后,再做输出,输出过程只能用一个循环语句实现,不能分成两个部分。
Input
第一行输入整数n,代表下面有n行输入;
之后输入n行,每行先输入整数len与整数m(分别代表本表的元素总数与前半表的元素个数),之后输入len个整数,代表对应顺序表的每个元素。
Output
输出有n行,为每个顺序表前m个元素与后(len-m)个元素交换后的结果
Sample Input
2
10 3 1 2 3 4 5 6 7 8 9 10
5 3 10 30 20 50 80
Sample Output
4 5 6 7 8 9 10 1 2 3
50 80 10 30 20
#include <iostream>

using namespace std;

typedef struct
{
    int *elem;
    int len;
    int listsize;
}List;

void Creatlist(List &L,int n)
{
    L.elem=new int;
    for(int i=0;i<n;i++)
    {
      cin>>L.elem;
    }
}

void Move(List &L,int len,int m)
{
    int i,t;
    while(m--)
    {
            t=L.elem;
      for(i=1;i<len;i++)
      {
            L.elem=L.elem;
      }
      L.elem=t;
    }
}

void print(List &L,int len)
{
    int i;
    for(i=0;i<len;i++){
      if(i==len-1)
            cout<<L.elem<<endl;
      else
            cout<<L.elem<<" ";
    }
}

int main()
{
    int n,len,m;
    cin>>n;
    List L;
    while(n--)
    {
      cin>>len>>m;
      Creatlist(L,len);
      Move(L,len,m);
      print(L,len);
    }
    return 0;
}


文档来源:51CTO技术博客https://blog.51cto.com/u_15317888/3231848
页: [1]
查看完整版本: 顺序表应用3:元素位置互换之移位算法