评论

收藏

[R语言] hdu 5791 Two dp

编程语言 编程语言 发布于:2021-07-21 16:32 | 阅读数:282 | 评论:0

Two


题目连接:
http://acm.hdu.edu.cn/showproblem.php?pid=5791

Description
Alice gets two sequences A and B. A easy problem comes. How many pair of sequence A' and sequence B' are same. For example, {1,2} and {1,2} are same. {1,2,4} and {1,4,2} are not same. A' is a subsequence of A. B' is a subsequence of B. The subsequnce can be not continuous. For example, {1,1,2} has 7 subsequences {1},{1},{2},{1,1},{1,2},{1,2},{1,1,2}. The answer can be very large. Output the answer mod 1000000007.

Input
The input contains multiple test cases.
For each test case, the first line cantains two integers N,M(1≤N,M≤1000). The next line contains N integers. The next line followed M integers. All integers are between 1 and 1000.

Output
For each test case, output the answer mod 1000000007.

Sample Input
3 2
1 2 3
2 1
3 2
1 2 3
1 2

Sample Output
2
3

Hint

题意
给你两个数组,问你公共子序列的数量是多少

题解:
dp[j]表示第一个串考虑到i位,第二个串考虑到j位的答案是多少
那么dp[j] = dp[i-1][j]+dp[j-1]-dp[i-1][j-1]
如果a=b[j],dp[j]+=dp[i-1][j-1]+1
就好了

代码
#include <bits/stdc++.h>
using namespace std;
const int pr=1000000007;
int dp[2010][2010];
int n,m;
int a[2010],b[2010];
int main()
{
  while(scanf("%d%d",&n,&m)!=EOF)
  {
    for(int i=1;i<=n;i++)
      for(int j=1;j<=m;j++) dp[i][j]=0;
    for(int i=1;i<=n;i++)
      scanf("%d",&a[i]);
    for(int i=1;i<=m;i++)
      scanf("%d",&b[i]);
   //   for(int i=1;i<=n;i++) dp[i][0]=1;
   //   for(int i=1;i<=m;i++) dp[0][i]=1;
    for(int i=1;i<=n;i++)
    {
      for(int j=1;j<=m;j++)
      {
        dp[i][j]=dp[i-1][j]+dp[i][j-1]-dp[i-1][j-1];
        if(a[i]==b[j]) dp[i][j]+=dp[i-1][j-1]+1;
        if(dp[i][j]<0) dp[i][j]+=pr;
        if(dp[i][j]>=pr) dp[i][j]%=pr;
       //   cout<<i<<" "<<j<<" "<<dp[i][j]<<endl;
      }
    }
    cout<<dp[n][m]<<endl;
  }
  return 0;
}

关注下面的标签,发现更多相似文章