评论

收藏

[R语言] 顺序表应用6:有序顺序表查询

编程语言 编程语言 发布于:2021-07-31 18:12 | 阅读数:202 | 评论:0

顺序表应用6:有序顺序表查询
Time Limit: 1000 ms Memory Limit: 4096 KiB
Submit Statistic
Problem Description
顺序表内按照由小到大的次序存放着n个互不相同的整数,任意输入一个整数,判断该整数在顺序表中是否存在。如果在顺序表中存在该整数,输出其在表中的序号;否则输出“No Found!"。
Input
第一行输入整数n (1 <= n <= 100000),表示顺序表的元素个数;
第二行依次输入n个各不相同的有序非负整数,代表表里的元素;
第三行输入整数t (1 <= t <= 100000),代表要查询的次数;
第四行依次输入t个非负整数,代表每次要查询的数值。
保证所有输入的数都在 int 范围内。
Output
输出t行,代表t次查询的结果,如果找到在本行输出该元素在表中的位置,否则本行输出No Found!
Sample Input
10
1 22 33 55 63 70 74 79 80 87
4
55 10 2 87
Sample Output
4
No Found!
No Found!
10
#include <iostream>
using namespace std;
typedef struct
{
  int *elem;
  int length;
  int Listsize;
}List;
void CreateList(List &L,int n)
{
  L.elem=new int [100001];
  L.length=n;
  for(int i=0;i<=n-1;i++)
  {
    cin>>L.elem[i];
  }
}
int find(List &L,int high,int low,int key)
{
  while(low<=high)
  {
    int mid=(high+low)/2;
    if(L.elem[mid]==key)return mid+1;
    else if(L.elem[mid]>key)high=mid-1;
    else if(L.elem[mid]<key)low=mid+1;
  }
  return -1;
}
int main()
{
  List L;
  int n;
  cin>>n;
  CreateList(L,n);
  int t;
  cin>>t;
  while(t--)
  {
    int x;
    cin>>x;
    int y;
    y=find(L,n-1,0,x);
    if(y==-1)cout<<"No Found!"<<endl;
    else   cout<<y<<endl;
  }
  return 0;
}

关注下面的标签,发现更多相似文章