评论

收藏

[C++] BZOJ 1008 [HNOI2008]越狱 排列组合

编程语言 编程语言 发布于:2021-07-17 14:05 | 阅读数:431 | 评论:0


1008: [HNOI2008]越狱
Time Limit: 1 Sec  Memory Limit: 162 MB
Submit: 4788  Solved: 2060
[Submit][Status][Discuss]


Description
监狱有连续编号为1...N的N个房间,每个房间关押一个犯人,有M种宗教,每个犯人可能信仰其中一种。如果相邻房间的犯人的宗教相同,就可能发生越狱,求有多少种状态可能发生越狱

Input

输入两个整数M,N.1<=M<=10^8,1<=N<=10^12

Output

可能越狱的状态数,模100003取余

Sample Input

2 3

Sample Output

6

HINT
6种状态为(000)(001)(011)(100)(110)(111)
题解
有n个监狱,m个信仰,那么总共有n^m的种类
不可行的,手动随便推一下就知道,是m*(m-1)^(n-1)种
然后快速幂搞一搞就好啦!
但是!直接减有可能出现负数,所以得加上一个mod再减
//qscqesze
#include <cstdio>
#include <cmath>
#include <cstring>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <set>
#include <vector>
#include <sstream>
#include <queue>
#include <typeinfo>
#include <fstream>
#include <map>
typedef long long ll;
using namespace std;
//freopen("D.in","r",stdin);
//freopen("D.out","w",stdout);
#define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
#define maxn 100001
#define eps 1e-9
const int inf=9999999;   //无限大
//**************************************************************************************
int MOD=100003;
ll powmod(ll a,ll b) {
  ll ans = 1,x = a;
  while (b) {
    if (b & 1) ans = ans * x % MOD;
    x = x * x % MOD;
    b >>= 1;
  }
  return ans;
}
int main()
{
  ll m;
  ll n;
  cin>>m>>n;
  ll kiss=powmod(m,n);
  cout<<(kiss+MOD-(m*powmod(m-1,n-1))%MOD)%MOD<<endl;
}



关注下面的标签,发现更多相似文章