评论

收藏

[R语言] hdu 1024 Max Sum Plus Plus DP

编程语言 编程语言 发布于:2021-07-20 20:29 | 阅读数:440 | 评论:0

Max Sum Plus PlusTime Limit: 1 Sec  Memory Limit: 256 MB

题目连接
http://acm.hdu.edu.cn/showproblem.php?pid=1024

Description

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

Input

Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.

Output
Output the maximal summation described above in one line.

Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8

HINT
题意
给你n个数,让你选择连续的M段,让你得到最大值
题解:

简单的想一想,dp[j]表示,前j个数,我选i段的最大值,那么转移方程,dp[j]=max(dp[j-1]+a[j],dp[i-1][k]+a[j])
然后滚动数组优化一下
代码:
//qscqesze
#include <cstdio>
#include <cmath>
#include <cstring>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <set>
#include <vector>
#include <sstream>
#include <queue>
#include <typeinfo>
#include <fstream>
#include <map>
#include <stack>
typedef long long ll;
using namespace std;
//freopen("D.in","r",stdin);
//freopen("D.out","w",stdout);
#define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
#define maxn 1000005
#define mod 10007
#define eps 1e-9
int Num;
char CH[20];
//const int inf=0x7fffffff;   //нчоч╢С
const int inf=0x3f3f3f3f;
/*
inline void P(int x)
{
  Num=0;if(!x){putchar('0');puts("");return;}
  while(x>0)CH[++Num]=x%10,x/=10;
  while(Num)putchar(CH[Num--]+48);
  puts("");
}
*/
//**************************************************************************************
inline int read()
{
  int x=0,f=1;char ch=getchar();
  while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
  while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
  return x*f;
}
inline void P(int x)
{
  Num=0;if(!x){putchar('0');puts("");return;}
  while(x>0)CH[++Num]=x%10,x/=10;
  while(Num)putchar(CH[Num--]+48);
  puts("");
}
int dp[maxn+10];
int mmax[maxn+10];
int a[maxn+10];
int main()
{
  int n,m;
  int i,j,mmmax;
  while(scanf("%d%d",&m,&n)!=EOF)
  {
    for(i=1;i<=n;i++)
    {
      scanf("%d",&a[i]);
      mmax[i]=0;
      dp[i]=0;
    }
    dp[0]=0;
    mmax[0]=0;
    for(i=1;i<=m;i++)
    {
        mmmax=-inf;
        for(j=i;j<=n;j++)
        {
          dp[j]=max(dp[j-1]+a[j],mmax[j-1]+a[j]);
          mmax[j-1]=mmmax;
          mmmax=max(mmmax,dp[j]);
        }
    }
    printf("%d\n",mmmax);
  }
  return 0;
}



关注下面的标签,发现更多相似文章