import java.util.Scanner;
public class Main
{
public static void main(String[] args)
{
Scanner reader = new Scanner(System.in);
int N = reader.nextInt();
for(int i=1;i<=N;i++)
{
int M=N*i;
System.out.printf("%d*%d=%d\n",N,i,M);
}
}
}
C语言实验——for循环打印图形(循环结构)
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description
通过使用双重for循环语句,打印下列图形:
提交
Input
Output
Sample Input
Sample Output
*
*
期末考试之分等级
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description
期末考试结束了,老师想要根据学生们的成绩划分出等级。共有5个等级A,B,C,D和E。
划分方法如下,90分(含90)以上的为A,80~90(含80)间的为B,70~80(含70)间的为C,
60~70(含60)的为D,不及格的为E。
根据输入的成绩,编程输出各个级别段人数。
Input
输入第一行包含一个正整数N(N<= 100)代表学生的数目,接下来有N行数据每行一个整数(0~100)代表
一个学生的成绩。
Output
输出有五行格式如下:
A nA
B nB
C nC
D nD
E nE
其中A,B,C,D,E代表等级,nA,nB等代表个等级的人数,等级和人数之间有一个空格。
Sample Input
6
66
73
85
99
100
59
Sample Output
A 2
B 1
C 1
D 1
E 1
import java.util.Scanner;
public class Main
{
public static void main(String[] args)
{
Scanner reader = new Scanner(System.in);
int N=reader.nextInt();
int a=0,b=0,c=0,d=0,e=0;
for(int i=1;i<=N;i++)
{
int X=reader.nextInt();
if(X>=90)a++;
else if(X>=80)b++;
else if(X>=70)c++;
else if(X>=60)d++;
else e++;
}
System.out.printf("A %d\nB %d\nC %d\nD %d\nE %d\n",a,b,c,d,e);
}
}
import java.util.Scanner;
import com.sun.jndi.url.iiopname.iiopnameURLContextFactory;
public class Main
{
public static void main(String[] args)
{
Scanner reader = new Scanner(System.in);
int A[];
A=new int [101];
int N=reader.nextInt();
for(int i=0;i<=N-1;i++)
{
int a=reader.nextInt();
int b=reader.nextInt();
int c=reader.nextInt();
A[i]=a+b+c;
}
int t;
for(int i=0;i<=N-2;i++)
{
for(int j=0;j<=N-2-i;j++)
{
if(A[j]<A[j+1])
{
t=A[j];A[j]=A[j+1];A[j+1]=t;
}
}
}
for(int i=0;i<=N-1;i++)
{
System.out.printf("%d\n",A[i]);
}
}
}